JavaScript is disabled. For a much better experience, please permit JavaScript in her browser prior to proceeding.

You are watching: 2002 chevy silverado service engine soon light flashing


Alright i have a 2003 silverado 2500hd 6.0l for my work-related truck. It has actually 95000 mile on it, the engine sounds healthy and it runs great 99% the the time. My concern is about the organization engine soon light. It will certainly not go off no matter what ns do, it has actually been on since around 75000 miles if i remember correctly. The irradiate flashes occasionally when i go over 75 mph and also if i have it in tow / to draw it flicker if you walk over 50 mph. Anybody understand why the does this?
*

*

Based on the variety of responses I view on google because that this symptom, I"m going to litter my poll in for "Get the scanned ASAP"I in reality dropped a pretty penny on a scan device (AutoXray 5000) a couple of years ago just for these mysterious SES lights. Got exhausted of having to find a shop or components store. Thanks to smartphones, you can now get collection up for under 50 bucks...
Well ns wasn"t really to worried around it since i rarely go 75mph or use the tow/haul because its my firm work truck, however i put gas in the yesterday (same grade as constantly 87) in ~ a different gas station and also the light turned off. I went top top the highway and went 75mph and also the didn"t flash, ns turned ~ above tow haul and went 50mph favor before and also it did no flash. Possibly the gas station i have actually been using to to fill my truck up has something in the gas that the van does not like? concerned think that it the gas station recently started adding an ext ethonal* come the fuel. Might that probably be it?
E85 possibly, yes. Personal I"d go out of my way to protect against that swill. If non-E85 ever goes extinct, I"m gettin" a Duramax.
Well ns wasn"t yes, really to worried around it due to the fact that i seldom go 75mph or usage the tow/haul because its my company work truck, yet i placed gas in the yesterday (same class as always 87) in ~ a different gas station and also the irradiate turned off. Ns went ~ above the highway and also went 75mph and also the didn"t flash, ns turned ~ above tow haul and also went 50mph favor before and it did not flash. Probably the gas station i have been using to fill my van up has something in the gas that the truck does not like? concerned think that it the gas station freshly started adding more ethonal* come the fuel. Could that probably be it?
I review something somewhere around possibly cram a code once you adjust fuel types, however can"t remember currently where I witnessed it. At any type of rate, I"m suspicious of coincidences, and also just coincidentally, the one time my 1999 threw me the "service engine soon" code I had tried a mid-grade fuel because that the very first time ever, and the really next time I started the truck, there to be the code. I had Autozone erase the code, placed my normal fuel in the from that allude onward, and also did not acquire the code/message again. No saying various fuel was the cause, but.... And also sometimes we have finicky or staticky sensors.
Did you ever before get resolution ~ above this issue? I have actually what I believe to it is in the very same problem, however it it s okay tougher and tougher to prevent ethanol.

See more: More Holes Salt Or Pepper Shaker : The Hole Story, Which Has More Holes Salt Or Pepper Shaker


I know this is an old thread, yet i have to throw this in because that anyone searching. This is somewhat typical on the 6.0. More than likely, the truck needs a crank relearn procedure. Mine 2000 and also 2003 both compelled this service. Ns chased each with parts and a live data scanner. The 03 threw codes that led me to think it essential this service. The 2000 on the other hand, just flashed. Take it it come someone through a technology 2 scanner. They will certainly tell you. The procedure should take/cost less than an hours labor
I too have actually SES irradiate issues. I"m told the is intend to show up each and every time the ignition is turned come the ~ above position; mine comes on sometimes and also not others. I"ve had it scanned and also found no codes. Disconnected battery in effort to clean this concern without success. Any kind of ideas or referrals will be appreciated.